const regex = /Last in.* {10,}w|(Last in.*[0-9][0-9]w[0-7]d|[0-9]y|outp.*[0-9][0-9]w[0-7]d|[0-9]y)|disabled|Last input never, output never, output hang never/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Last in.* {10,}w|(Last in.*[0-9][0-9]w[0-7]d|[0-9]y|outp.*[0-9][0-9]w[0-7]d|[0-9]y)|disabled|Last input never, output never, output hang never', 'gm')
const str = `GigabitEthernet0/2 is down, line protocol is down (notconnect)
Last input never, output never, output hang never
GigabitEthernet0/3 is down, line protocol is down (notconnect)
GigabitEthernet0/4 is down, line protocol is down (notconnect)
Last input 23w0d, output 23w0d, output hang never
GigabitEthernet0/5 is down, line protocol is down (notconnect)
Last input 23w0d, output 23w0d, output hang never
GigabitEthernet0/6 is down, line protocol is down (notconnect)
Last input 11w5d, output 1w4d, output hang never
Last input 11w5d, output 00:00:01, output hang never
Last input never, output never, output hang never
GigabitEthernet0/12 is down, line protocol is down (notconnect)
Last input never, output never, output hang never
GigabitEthernet0/2 is administratively down, line protocol is down (disabled)
Last input never, output never, output hang never
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}