import Foundation
let pattern = #"Last in.* {10,}w|(Last in.*[0-9][0-9]w[0-7]d|[0-9]y|outp.*[0-9][0-9]w[0-7]d|[0-9]y)|disabled|Last input never, output never, output hang never"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
GigabitEthernet0/2 is down, line protocol is down (notconnect)
Last input never, output never, output hang never
GigabitEthernet0/3 is down, line protocol is down (notconnect)
GigabitEthernet0/4 is down, line protocol is down (notconnect)
Last input 23w0d, output 23w0d, output hang never
GigabitEthernet0/5 is down, line protocol is down (notconnect)
Last input 23w0d, output 23w0d, output hang never
GigabitEthernet0/6 is down, line protocol is down (notconnect)
Last input 11w5d, output 1w4d, output hang never
Last input 11w5d, output 00:00:01, output hang never
Last input never, output never, output hang never
GigabitEthernet0/12 is down, line protocol is down (notconnect)
Last input never, output never, output hang never
GigabitEthernet0/2 is administratively down, line protocol is down (disabled)
Last input never, output never, output hang never
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)