# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Last in.* {10,}w|(Last in.*[0-9][0-9]w[0-7]d|[0-9]y|outp.*[0-9][0-9]w[0-7]d|[0-9]y)|disabled|Last input never, output never, output hang never"
test_str = ("GigabitEthernet0/2 is down, line protocol is down (notconnect) \n"
" Last input never, output never, output hang never\n"
"GigabitEthernet0/3 is down, line protocol is down (notconnect) \n"
"GigabitEthernet0/4 is down, line protocol is down (notconnect) \n"
" Last input 23w0d, output 23w0d, output hang never\n"
"GigabitEthernet0/5 is down, line protocol is down (notconnect) \n"
" Last input 23w0d, output 23w0d, output hang never\n"
"GigabitEthernet0/6 is down, line protocol is down (notconnect) \n"
" Last input 11w5d, output 1w4d, output hang never\n"
" Last input 11w5d, output 00:00:01, output hang never\n"
" Last input never, output never, output hang never\n"
"GigabitEthernet0/12 is down, line protocol is down (notconnect) \n"
" Last input never, output never, output hang never\n"
"GigabitEthernet0/2 is administratively down, line protocol is down (disabled) \n"
" Last input never, output never, output hang never\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.