import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Last in.* {10,}w|(Last in.*[0-9][0-9]w[0-7]d|[0-9]y|outp.*[0-9][0-9]w[0-7]d|[0-9]y)|disabled|Last input never, output never, output hang never";
final String string = "GigabitEthernet0/2 is down, line protocol is down (notconnect) \n"
+ " Last input never, output never, output hang never\n"
+ "GigabitEthernet0/3 is down, line protocol is down (notconnect) \n"
+ "GigabitEthernet0/4 is down, line protocol is down (notconnect) \n"
+ " Last input 23w0d, output 23w0d, output hang never\n"
+ "GigabitEthernet0/5 is down, line protocol is down (notconnect) \n"
+ " Last input 23w0d, output 23w0d, output hang never\n"
+ "GigabitEthernet0/6 is down, line protocol is down (notconnect) \n"
+ " Last input 11w5d, output 1w4d, output hang never\n"
+ " Last input 11w5d, output 00:00:01, output hang never\n"
+ " Last input never, output never, output hang never\n"
+ "GigabitEthernet0/12 is down, line protocol is down (notconnect) \n"
+ " Last input never, output never, output hang never\n"
+ "GigabitEthernet0/2 is administratively down, line protocol is down (disabled) \n"
+ " Last input never, output never, output hang never\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}