using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href.+?[\'|\""]+?([^\'|\""]+)?[\'|\""]";
string input = @"<a href='http://matrix.ms.com/"" target=""_blank"" data-saferedirecturl=""https://www.google.com/url?q=http://matrix.ms.com/&source=gmail&ust=1591284067791000&usg=AFQjCNGSmpctZFZau9kOCv8xa9Abu8a-uQ"">Matrix.ms.com</a>
<a href=""http://matrix.ms.com/"" target=""_blank"" data-saferedirecturl=""https://www.google.com/url?q=http://matrix.ms.com/&source=gmail&ust=1591284067791000&usg=AFQjCNGSmpctZFZau9kOCv8xa9Abu8a-uQ"">Matrix.ms.com</a>
a.+?href.+?[\'|\""]+?([^\'|\""]+)?[\'|\""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}