import Foundation
let pattern = #"href.+?[\'|\"]+?([^\'|\"]+)?[\'|\"]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<a href='http://matrix.ms.com/" target="_blank" data-saferedirecturl="https://www.google.com/url?q=http://matrix.ms.com/&source=gmail&ust=1591284067791000&usg=AFQjCNGSmpctZFZau9kOCv8xa9Abu8a-uQ">Matrix.ms.com</a>
<a href="http://matrix.ms.com/" target="_blank" data-saferedirecturl="https://www.google.com/url?q=http://matrix.ms.com/&source=gmail&ust=1591284067791000&usg=AFQjCNGSmpctZFZau9kOCv8xa9Abu8a-uQ">Matrix.ms.com</a>
a.+?href.+?[\'|\"]+?([^\'|\"]+)?[\'|\"]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)