const regex = /href.+?[\'|\"]+?([^\'|\"]+)?[\'|\"]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href.+?[\\\'|\\"]+?([^\\\'|\\"]+)?[\\\'|\\"]', 'gm')
const str = `<a href='http://matrix.ms.com/" target="_blank" data-saferedirecturl="https://www.google.com/url?q=http://matrix.ms.com/&source=gmail&ust=1591284067791000&usg=AFQjCNGSmpctZFZau9kOCv8xa9Abu8a-uQ">Matrix.ms.com</a>
<a href="http://matrix.ms.com/" target="_blank" data-saferedirecturl="https://www.google.com/url?q=http://matrix.ms.com/&source=gmail&ust=1591284067791000&usg=AFQjCNGSmpctZFZau9kOCv8xa9Abu8a-uQ">Matrix.ms.com</a>
a.+?href.+?[\\'|\\"]+?([^\\'|\\"]+)?[\\'|\\"]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}