#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Z ]+(?<! )"
Local $sString = "замечательный греческий набор SWAP с цветами" & @CRLF & _
"Классная зубная паста WILD NATURE со вкусом орехов" & @CRLF & _
"Классная зубная паста WILD NATURE THREE со вкусом орехов" & @CRLF & _
"Классная зубная паста WILD NATURE THREE FOUR со вкусом орехов"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")