$re = '/\b[A-Z ]+(?<! )/m';
$str = 'замечательный греческий набор SWAP с цветами
Классная зубная паста WILD NATURE со вкусом орехов
Классная зубная паста WILD NATURE THREE со вк усом орехов
Классная зубная паста WILD NATURE THREE FOUR со вкусом орехов';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);