using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Z ]+(?<! )";
string input = @"замечательный греческий набор SWAP с цветами
Классная зубная паста WILD NATURE со вкусом орехов
Классная зубная паста WILD NATURE THREE со вкусом орехов
Классная зубная паста WILD NATURE THREE FOUR со вкусом орехов";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}