const regex = /\b[A-Z ]+(?<! )/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z ]+(?<! )', 'gm')
const str = `замечательный греческий набор SWAP с цветами
Классная зубная паста WILD NATURE со вкусом орехов
Классная зубная паста WILD NATURE THREE со вкусом орехов
Классная зубная паста WILD NATURE THREE FOUR со вкусом орехов`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}