re = /\b[A-Z ]+(?<! )/m
str = 'замечательный греческий набор SWAP с цветами
Классная зубная паста WILD NATURE со вкусом орехов
Классная зубная паста WILD NATURE THREE со вкусом орехов
Классная зубная паста WILD NATURE THREE FOUR со вкусом орехов'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end