# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\h*,\h*)+ # Leading commas
|
(?:\h*,\h*)+$ # Ending commas
|
,\h*(?=,\h*) # Commas followed by commas//gmx;t' <<< "Av. de Lavaux, 31, , , 1009 Pully, VD,
, 45, 3rd floor, , 8000 Zürich, ZH, Switzerland
Test, 8, , +41 77 800 80 80, , ,
, ,, the last test,, USA"