import re
regex = re.compile(r"""
^(?:\h*,\h*)+ # Leading commas
|
(?:\h*,\h*)+$ # Ending commas
|
,\h*(?=,\h*) # Commas followed by commas
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("Av. de Lavaux, 31, , , 1009 Pully, VD,\n"
", 45, 3rd floor, , 8000 Zürich, ZH, Switzerland\n"
"Test, 8, , +41 77 800 80 80, , ,\n"
", ,, the last test,, USA")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)