import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\h*,\\h*)+ # Leading commas\n"
+ "|\n"
+ "(?:\\h*,\\h*)+$ # Ending commas\n"
+ "|\n"
+ ",\\h*(?=,\\h*) # Commas followed by commas";
final String string = "Av. de Lavaux, 31, , , 1009 Pully, VD,\n"
+ ", 45, 3rd floor, , 8000 Zürich, ZH, Switzerland\n"
+ "Test, 8, , +41 77 800 80 80, , ,\n"
+ ", ,, the last test,, USA";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}