$re = '/^(?:\h*,\h*)+ # Leading commas
|
(?:\h*,\h*)+$ # Ending commas
|
,\h*(?=,\h*) # Commas followed by commas/mx';
$str = 'Av. de Lavaux, 31, , , 1009 Pully, VD,
, 45, 3rd floor, , 8000 Zürich, ZH, Switzerland
Test, 8, , +41 77 800 80 80, , ,
, ,, the last test,, USA';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;