#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mx)^(?:\h*,\h*)+ # Leading commas" & @CRLF & _
"|" & @CRLF & _
"(?:\h*,\h*)+$ # Ending commas" & @CRLF & _
"|" & @CRLF & _
",\h*(?=,\h*) # Commas followed by commas"
Local $sString = "Av. de Lavaux, 31, , , 1009 Pully, VD," & @CRLF & _
", 45, 3rd floor, , 8000 Zürich, ZH, Switzerland" & @CRLF & _
"Test, 8, , +41 77 800 80 80, , ," & @CRLF & _
", ,, the last test,, USA"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)