using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([А-Я][а-я]+( |$)){2,3}";
string input = @"Иванов Иван Иванович
Иванов Иван
dgvbjggfcb hvvnkj fgjvcgg bgc
птьлопсмтьорпмитопмито
Иванов Иван Иванович";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}