import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([А-Я][а-я]+( |$)){2,3}";
final String string = "Иванов Иван Иванович\n"
+ "Иванов Иван\n"
+ " dgvbjggfcb hvvnkj fgjvcgg bgc\n"
+ " птьлопсмтьорпмитопмито\n"
+ "Иванов Иван Иванович";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}