const regex = /([А-Я][а-я]+( |$)){2,3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([А-Я][а-я]+( |$)){2,3}', 'gm')
const str = `Иванов Иван Иванович
Иванов Иван
dgvbjggfcb hvvnkj fgjvcgg bgc
птьлопсмтьорпмитопмито
Иванов Иван Иванович`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}