re = /([А-Я][а-я]+( |$)){2,3}/m
str = 'Иванов Иван Иванович
Иванов Иван
dgvbjggfcb hvvnkj fgjvcgg bgc
птьлопсмтьорпмитопмито
Иванов Иван Иванович'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end