$re = '/([А-Я][а-я]+( |$)){2,3}/m';
$str = 'Иванов Иван Иванович
Иванов Иван
dgvbjggfcb hvvnkj fgjvcgg bgc
птьлопсмтьорпмитопмито
Иванов Иван Иванович';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);