import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\?\\*|\\*\\?|(\\*|\\?)\\1)+(\\*|\\?)?";
final String string = "*?a?s?*?k?i?n?a?r?d?*?*?d?e?d?i?c?a?t?e?d?*?****r?e?g????i?o?n?a?l*";
final String subst = "*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}