use strict;
my $str = '*?a?s?*?k?i?n?a?r?d?*?*?d?e?d?i?c?a?t?e?d?*?****r?e?g????i?o?n?a?l*';
my $regex = qr/(?:\?\*|\*\?|(\*|\?)\1)+(\*|\?)?/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";