re = /(?:\?\*|\*\?|(\*|\?)\1)+(\*|\?)?/m
str = '*?a?s?*?k?i?n?a?r?d?*?*?d?e?d?i?c?a?t?e?d?*?****r?e?g????i?o?n?a?l*'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result