const regex = /(?:\?\*|\*\?|(\*|\?)\1)+(\*|\?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\?\\*|\\*\\?|(\\*|\\?)\\1)+(\\*|\\?)?', 'gm')
const str = `*?a?s?*?k?i?n?a?r?d?*?*?d?e?d?i?c?a?t?e?d?*?****r?e?g????i?o?n?a?l*`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);