#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^# /// (?P<type>[a-zA-Z0-9-]+)$\s(?P<content>(^#(| .*)$\s)+)^# ///$" & @CRLF & _
""
Local $sString = "# /// pyproject" & @CRLF & _
"# [run]" & @CRLF & _
"# dependencies = ["requests<3"]" & @CRLF & _
"# ///" & @CRLF & _
"#" & @CRLF & _
"# This data is still being read" & @CRLF & _
"# if someone has accidentally bridged" & @CRLF & _
"# two metadata blocks without a blank" & @CRLF & _
"# line or other data between them this " & @CRLF & _
"# will be included." & @CRLF & _
"#" & @CRLF & _
"# /// pyproject" & @CRLF & _
"# You might expect this to be a second" & @CRLF & _
"# pyproject block and cause an error but " & @CRLF & _
"# instead it will be picked up by the regex " & @CRLF & _
"# all as one block." & @CRLF & _
"# ///" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")