re = /(?m)^# \/\/\/ (?P<type>[a-zA-Z0-9-]+)$\s(?P<content>(^#(| .*)$\s)+)^# \/\/\/$
/m
str = '# /// pyproject
# [run]
# dependencies = ["requests<3"]
# ///
#
# This data is still being read
# if someone has accidentally bridged
# two metadata blocks without a blank
# line or other data between them this
# will be included.
#
# /// pyproject
# You might expect this to be a second
# pyproject block and cause an error but
# instead it will be picked up by the regex
# all as one block.
# ///
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end