using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^# /// (?P<type>[a-zA-Z0-9-]+)$\s(?P<content>(^#(| .*)$\s)+)^# ///$
";
string input = @"# /// pyproject
# [run]
# dependencies = [""requests<3""]
# ///
#
# This data is still being read
# if someone has accidentally bridged
# two metadata blocks without a blank
# line or other data between them this
# will be included.
#
# /// pyproject
# You might expect this to be a second
# pyproject block and cause an error but
# instead it will be picked up by the regex
# all as one block.
# ///
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}