import re
regex = re.compile((r"(?m)^# /// (?P<type>[a-zA-Z0-9-]+)$\s(?P<content>(^#(| .*)$\s)+)^# ///$\n"), flags=re.MULTILINE)
test_str = ("# /// pyproject\n"
"# [run]\n"
"# dependencies = [\"requests<3\"]\n"
"# ///\n"
"#\n"
"# This data is still being read\n"
"# if someone has accidentally bridged\n"
"# two metadata blocks without a blank\n"
"# line or other data between them this \n"
"# will be included.\n"
"#\n"
"# /// pyproject\n"
"# You might expect this to be a second\n"
"# pyproject block and cause an error but \n"
"# instead it will be picked up by the regex \n"
"# all as one block.\n"
"# ///\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")