#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\btracks\/.*)(?<!\d)\d{9}(?!\d)"
Local $sString = "The string tracks/ is followed by 123456789 blah blah" & @CRLF & _
"The string tracks/ is followed by 1234567890 blah blah" & @CRLF & _
"The string tracks/ is followed by 12345678 blah blah" & @CRLF & _
"The string 123456789 is followed by tracks/ blah blah" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")