$re = '/(?<=\btracks\/.*)(?<!\d)\d{9}(?!\d)/m';
$str = 'The string tracks/ is followed by 123456789 blah blah
The string tracks/ is followed by 1234567890 blah blah
The string tracks/ is followed by 12345678 blah blah
The string 123456789 is followed by tracks/ blah blah
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);