const regex = /(?<=\btracks\/.*)(?<!\d)\d{9}(?!\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\btracks\\\/.*)(?<!\\d)\\d{9}(?!\\d)', 'gm')
const str = `The string tracks/ is followed by 123456789 blah blah
The string tracks/ is followed by 1234567890 blah blah
The string tracks/ is followed by 12345678 blah blah
The string 123456789 is followed by tracks/ blah blah
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}