use strict;
my $str = 'The string tracks/ is followed by 123456789 blah blah
The string tracks/ is followed by 1234567890 blah blah
The string tracks/ is followed by 12345678 blah blah
The string 123456789 is followed by tracks/ blah blah
';
my $regex = qr/(?<=\btracks\/.*)(?<!\d)\d{9}(?!\d)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}