using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\btracks\/.*)(?<!\d)\d{9}(?!\d)";
string input = @"The string tracks/ is followed by 123456789 blah blah
The string tracks/ is followed by 1234567890 blah blah
The string tracks/ is followed by 12345678 blah blah
The string 123456789 is followed by tracks/ blah blah
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}