const regex = /(?<partnumber>\d{4}\.\d{3}\.\d{3})\s+(\d+)\s+(\d+)\s+(\d+\,\d+)\s+(\d+)\s+(\d+\,\d+)\s+(.*?)\sHS\.code: (\d+) Country of origin: ([A-Z\/]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<partnumber>\\d{4}\\.\\d{3}\\.\\d{3})\\s+(\\d+)\\s+(\\d+)\\s+(\\d+\\,\\d+)\\s+(\\d+)\\s+(\\d+\\,\\d+)\\s+(.*?)\\sHS\\.code: (\\d+) Country of origin: ([A-Z\\\/]+)', 'gm')
const str = `11 4149.310.025 000 1 37,78 1 37,78
PISTON
HS.code: 87084099 Country of origin: EU/DE
EAN: 2050000141478
21 0734.401.251 000 4 3,05 1 12,20
PISTON RING
HS.code: 73182100 Country of origin: JP
EAN: 2050000026638"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}