import re
regex = re.compile(r"(?<partnumber>\d{4}\.\d{3}\.\d{3})\s+(\d+)\s+(\d+)\s+(\d+\,\d+)\s+(\d+)\s+(\d+\,\d+)\s+(.*?)\sHS\.code: (\d+) Country of origin: ([A-Z\/]+)", flags=re.MULTILINE)
test_str = ("11 4149.310.025 000 1 37,78 1 37,78\n"
"PISTON\n"
"HS.code: 87084099 Country of origin: EU/DE\n"
"EAN: 2050000141478\n"
"21 0734.401.251 000 4 3,05 1 12,20\n"
"PISTON RING\n"
"HS.code: 73182100 Country of origin: JP\n"
"EAN: 2050000026638\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")