// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<partnumber>\d{4}\.\d{3}\.\d{3})\s+(\d+)\s+(\d+)\s+(\d+\,\d+)\s+(\d+)\s+(\d+\,\d+)\s+(.*?)\sHS\.code: (\d+) Country of origin: ([A-Z\/]+)").unwrap();
let string = "11 4149.310.025 000 1 37,78 1 37,78
PISTON
HS.code: 87084099 Country of origin: EU/DE
EAN: 2050000141478
21 0734.401.251 000 4 3,05 1 12,20
PISTON RING
HS.code: 73182100 Country of origin: JP
EAN: 2050000026638\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}