#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z]{6}\d{2}[A-Za-z]\d{2}[A-Za-z]\d{3}[A-Za-z]$"
Local $sString = "FTNPZT92A15E738I" & @CRLF & _
"YDGGMN73M03L018A" & @CRLF & _
"CDSZXW93A26L613M" & @CRLF & _
"SKRZKW36B29Z730F" & @CRLF & _
"SKRZKW36B29Z7304" & @CRLF & _
"SKRZKW36B29Z73EF" & @CRLF & _
"SKRzkW36B29Z730f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")