re = /^[A-Za-z]{6}\d{2}[A-Za-z]\d{2}[A-Za-z]\d{3}[A-Za-z]$/m
str = 'FTNPZT92A15E738I
YDGGMN73M03L018A
CDSZXW93A26L613M
SKRZKW36B29Z730F
SKRZKW36B29Z7304
SKRZKW36B29Z73EF
SKRzkW36B29Z730f'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end