// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z]{6}\d{2}[A-Za-z]\d{2}[A-Za-z]\d{3}[A-Za-z]$").unwrap();
let string = "FTNPZT92A15E738I
YDGGMN73M03L018A
CDSZXW93A26L613M
SKRZKW36B29Z730F
SKRZKW36B29Z7304
SKRZKW36B29Z73EF
SKRzkW36B29Z730f";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}