const regex = /^[A-Za-z]{6}\d{2}[A-Za-z]\d{2}[A-Za-z]\d{3}[A-Za-z]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z]{6}\\d{2}[A-Za-z]\\d{2}[A-Za-z]\\d{3}[A-Za-z]$', 'gm')
const str = `FTNPZT92A15E738I
YDGGMN73M03L018A
CDSZXW93A26L613M
SKRZKW36B29Z730F
SKRZKW36B29Z7304
SKRZKW36B29Z73EF
SKRzkW36B29Z730f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}