using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z]{6}\d{2}[A-Za-z]\d{2}[A-Za-z]\d{3}[A-Za-z]$";
string input = @"FTNPZT92A15E738I
YDGGMN73M03L018A
CDSZXW93A26L613M
SKRZKW36B29Z730F
SKRZKW36B29Z7304
SKRZKW36B29Z73EF
SKRzkW36B29Z730f";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}