#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(([a-zA-Z0-9]*)([^a-zA-Z0-9])([a-zA-Z0-9]*)([^a-zA-Z0-9]).)"
Local $sString = "123456" & @CRLF & _
"JeConsulteMesEmailsHELMoTousLesJours" & @CRLF & _
"www,H3LM0.be" & @CRLF & _
"abc123" & @CRLF & _
"japeJ2017labCm1$$" & @CRLF & _
"password" & @CRLF & _
"shadow" & @CRLF & _
"0nVrSl'33D_" & @CRLF & _
"gHt3Eé2BdCeMaT1" & @CRLF & _
"azerty" & @CRLF & _
"aGuD+33t-MiJa" & @CRLF & _
"KrZ,èVmZiFr" & @CRLF & _
"superman" & @CRLF & _
"iloveyou" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")