$re = '/(([a-zA-Z0-9]*)([^a-zA-Z0-9])([a-zA-Z0-9]*)([^a-zA-Z0-9]).)/m';
$str = '123456
JeConsulteMesEmailsHELMoTousLesJours
www,H3LM0.be
abc123
japeJ2017labCm1$$
password
shadow
0nVrSl\'33D_
gHt3Eé2BdCeMaT1
azerty
aGuD+33t-MiJa
KrZ,èVmZiFr
superman
iloveyou
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);