import re
regex = re.compile(r"(([a-zA-Z0-9]*)([^a-zA-Z0-9])([a-zA-Z0-9]*)([^a-zA-Z0-9]).)", flags=re.MULTILINE)
test_str = ("123456\n"
"JeConsulteMesEmailsHELMoTousLesJours\n"
"www,H3LM0.be\n"
"abc123\n"
"japeJ2017labCm1$$\n"
"password\n"
"shadow\n"
"0nVrSl'33D_\n"
"gHt3Eé2BdCeMaT1\n"
"azerty\n"
"aGuD+33t-MiJa\n"
"KrZ,èVmZiFr\n"
"superman\n"
"iloveyou\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")