using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([a-zA-Z0-9]*)([^a-zA-Z0-9])([a-zA-Z0-9]*)([^a-zA-Z0-9]).)";
string input = @"123456
JeConsulteMesEmailsHELMoTousLesJours
www,H3LM0.be
abc123
japeJ2017labCm1$$
password
shadow
0nVrSl'33D_
gHt3Eé2BdCeMaT1
azerty
aGuD+33t-MiJa
KrZ,èVmZiFr
superman
iloveyou
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}