re = /(([a-zA-Z0-9]*)([^a-zA-Z0-9])([a-zA-Z0-9]*)([^a-zA-Z0-9]).)/m
str = '123456
JeConsulteMesEmailsHELMoTousLesJours
www,H3LM0.be
abc123
japeJ2017labCm1$$
password
shadow
0nVrSl\'33D_
gHt3Eé2BdCeMaT1
azerty
aGuD+33t-MiJa
KrZ,èVmZiFr
superman
iloveyou
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end