#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[0-9]{2}){1,10}$"
Local $sString = "2" & @CRLF & _
"22" & @CRLF & _
"222" & @CRLF & _
"2222" & @CRLF & _
"22222" & @CRLF & _
"222222" & @CRLF & _
"2222222" & @CRLF & _
"22222222" & @CRLF & _
"22222222222222222222" & @CRLF & _
"222222222222222222222" & @CRLF & _
"2222222222222222222222"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")