package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[0-9]{2}){1,10}$`)
var str = `2
22
222
2222
22222
222222
2222222
22222222
22222222222222222222
222222222222222222222
2222222222222222222222`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}